Back to overview
Downtime

Network failure

May 18, 2026 at 12:43am UTC
Affected services
Showcase
DoYouBuzz
API
Boond Connector

Resolved
May 18, 2026 at 2:12am UTC

The incident has been resolved. DoYouBuzz is fully operational as of 4:00 AM.
A component of the network infrastructure caused a full network outage between 02:43 and 04:00 AM. The automatic failover did not trigger as expected due to the nature of the failure.

Our hosting provider's on-call team restored service within 1h15. No data was lost or compromised.

Going forward, our hosting provider has committed to faster automated failover (target: under 15 minutes) and a major firewall infrastructure upgrade planned for Q4 2026.

We apologize for the disruption.

Created
May 18, 2026 at 12:43am UTC

We are experiencing a platform-wide outage.